...
Poll

Best new addition or update ?

Discuss here

Hardware raffle
 
Serial key giveaways
 
Better game homepages
 
Nav bar
 
New skin
 
Vods & Live streams
 
    
Network

Follow, like, subscribe and share!

Facebook Twitter Steam You Tube
Shoutbox
You must be logged in to post a shout.
18/05/15 10:11pm
genuinely thought the site was RIP forever [*]
02/05/15 10:03am
SUP!
15/04/15 12:07am
iyur guys
08/04/15 9:30pm
Hey guys, sgl dead I take it? been years since I looked on here :P who's still alive and kicking then
31/03/15 8:17pm
is the site dead?
20/03/15 4:53pm
so err basically huhuhuhuh
20/03/15 1:34pm
here here
17/03/15 8:28pm
haii
14/03/15 8:37pm
herro

screenshots wont upload

Sat 25th Jun 2011 5:12am
SGLP: 100
Posts: 773 (0.23 a day)
Reputation: 6 You have already voted on this user
as it says above im on windows 7 dont know if anyone has had this problem any ideas?
Sat 25th Jun 2011 10:25am

SGLP: 100
Posts: 2001 (0.75 a day)
Reputation: 23 You have already voted on this user
Common issue with Windows 7 mate. Mine does the exact same. There was a post from theSGL about it somewhere but I can't find it 8(|)
Tue 9th Aug 2011 9:57pm
SGLP: 100
Posts: 2 (0 a day)
Reputation: 0 You have already voted on this user
my sgl make screens too and wound upload them
i have win7 what can i do that he upload the screens :/
Wed 10th Aug 2011 9:44pm
SGLP: 100
Posts: 2 (0 a day)
Reputation: 0 You have already voted on this user
????
Wed 10th Aug 2011 9:48pm

SGLP: 100
Posts: 1885 (0.64 a day)
Reputation: 28 You have already voted on this user
Its a common fault mate.. don't worry about it.
Add a reply
You must be logged in to add a reply.

div

Related Links

Follow, like, subscribe and share!

Facebook Twitter Steam You Tube
RTL Servers
Latest gaming movies
Latest gaming news
© theSGL.com 2004-2015 | Terms & conditions | Privacy policy | Page generated in 189.67 ms. 6 DB queries.
Warning